今天安装完Mysql后,开启发生了错误:

 

1、打开相应文件夹,查看错误信息:

 

2、打开错误信息文件,查看错误原因是:Plugin 'FEDERATED' is disabled. /usr/sbin/mysqld: Table 'mysql.plugin' doesn't exist

 

3、‘mysql.plugin’不存在的原因是因为新安装的mysql服务后,一般需要执行数据库初始化操作 ,从而生成与权限相关的表,执行命令如下:

/usr/bin/mysql_install_db --user=mysql

 

4、如果执行成功刚刚的命令当然是最好的,如果报出了以下错误:

解决方法是:安装autoconf库

yum -y install autoconf

 

5、接着执行数据库开启命令,就会成功啦!!!

service mysql start

 

小提示:数据库安装最好是安装在 usr/local/ 里面,因为默认的很多东西都是指向这个文件夹中的。

 

转载于:https://www.cnblogs.com/xieyupeng/p/8945297.html

Logo

魔乐社区(Modelers.cn) 是一个中立、公益的人工智能社区,提供人工智能工具、模型、数据的托管、展示与应用协同服务,为人工智能开发及爱好者搭建开放的学习交流平台。社区通过理事会方式运作,由全产业链共同建设、共同运营、共同享有,推动国产AI生态繁荣发展。

更多推荐