linux启动报Failed to mount sysroot修复
·
宿主机在一次服务器突然断电后,重新启动虚拟机时出现了挂载根目录失败的情况,然后直接进入了紧急模式

- 通过挂载iso光驱进入救援模式

- 查看之前系统的盘符

- 这里看到的是sda1盘并且是xfs文件系统
#尝试修复
xfs_repair /dev/sda1

- 这里修复报错了,加-L强制修复(生产环境谨慎使用)
#尝试强制修复
xfs_repair -L /dev/sda1

- 修复完成后并测试挂载,挂载没问题后重启

- 重启完成后顺利进入系统
魔乐社区(Modelers.cn) 是一个中立、公益的人工智能社区,提供人工智能工具、模型、数据的托管、展示与应用协同服务,为人工智能开发及爱好者搭建开放的学习交流平台。社区通过理事会方式运作,由全产业链共同建设、共同运营、共同享有,推动国产AI生态繁荣发展。
更多推荐


所有评论(0)