Caused by: java.sql.SQLSyntaxErrorException: SELECT command denied to user ‘xxx‘@‘localhost‘
·
后台报错,意思大致为,该用户(xxx)没有SELECT权限在localhost上.
一般出现在线上服务器上,语句库刚搬到线上,一些权限信息和线下配置不完全一样了.
解决方案:
可以直接修改权限:
grant all privileges on *.* to 'xxx用户名''@'localhost';
例如
grant all privileges on *.* to urban@'xxxxxx';
flush privileges;
注意: @ 后跟的访问方式,localhost指本地,%指所有.
然后刷新权限:
flush privileges;
这下,就能正常访问了.
魔乐社区(Modelers.cn) 是一个中立、公益的人工智能社区,提供人工智能工具、模型、数据的托管、展示与应用协同服务,为人工智能开发及爱好者搭建开放的学习交流平台。社区通过理事会方式运作,由全产业链共同建设、共同运营、共同享有,推动国产AI生态繁荣发展。
更多推荐


所有评论(0)