Mysql环境配置(Ubuntu 24.04 LTS)及mysql -u root -p命令显示ERROR 1698 (28000)错误的解决方法
·
涉及内容:mysql
背景:购入了一个腾讯云服务器,想将windows系统的本地项目部署上去,but 服务器本身甚也么有,有好多依赖得装啊,因此记录一下相关依赖的shell脚本
0. 前言,ssh登录
为了便于在本地折腾 (其实是我感觉腾讯云的orcaterm太不好使用了,老有延迟,感觉打个abcd都得卡一下)
-
先去弄一个ssh密钥。此步需关机。
-
创建密钥。点击创建密钥,然后起个名字,就好了。创建后会自动下载一个证书(不知道有啥用)。


-
去登陆。打开cmd。输入如下内容。之后输入给服务器设置的密码即可登陆成功。
ssh ubuntu@ip #例如ssh ubuntu@123.456.789.111

具体操作
0.先把更新抬上来
sudo apt update
1.查查能安装啥版本
sudo apt search mysql-server

2.安装,并摸鱼等待。我是懒人我选1。
sudo apt install -y mysql-server #不指定版本
sudo apt install -y mysql-server-8.0 #也可以指定版本
3.启动服务,并看看启动没。看到active (running)就成了。
sudo systemctl start mysql
sudo systemctl status mysql

4. 查看默认用户和密码。看use和对应的password,复制好。
sudo cat /etc/mysql/debian.cnf #查看默认密码

5.登录
mysql -u debian-sys-maint -p

5. 为啥不用root登录呢?
因为一些奇怪的原因,老显示权限问题,如下图。

可能的原因:在 Ubuntu 的新版本中,MySQL 通常默认为 root 用户使用 auth _ socket 插件,而不是基于密码的身份验证。所以得改一下。
ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'your_new_password';
FLUSH PRIVILEGES;
再试一次,果然好了。

魔乐社区(Modelers.cn) 是一个中立、公益的人工智能社区,提供人工智能工具、模型、数据的托管、展示与应用协同服务,为人工智能开发及爱好者搭建开放的学习交流平台。社区通过理事会方式运作,由全产业链共同建设、共同运营、共同享有,推动国产AI生态繁荣发展。
更多推荐


所有评论(0)