docker安装后,使用中经常出现:

Cannot connect to the Docker daemon at (unix:///var/run/docker.sock. Is the docker daemon running?) 

一、什么原因导致的:
触发此错误的一些原因包括:

The Docker daemon is not running.   Docker守护程序未运行。
Docker doesn’t shutdown cleanly.       Docker无法完全关闭。
Lack of root privileges to start the docker service.   缺少启动docker服务的root权限。

解决方法:

(1)在终端中执行 – unmask docker.

sudo systemctl unmask docker

如果docker被masked了,一般会有这样的提示:‘Failed to start docker.service: Unit is masked.’ 

(2)启动 start the docker daemon

systemctl start docker


(3)验证docker是否激活

systemctl status docker


如果出现以下内容,则已经激活了。

 

Logo

魔乐社区(Modelers.cn) 是一个中立、公益的人工智能社区,提供人工智能工具、模型、数据的托管、展示与应用协同服务,为人工智能开发及爱好者搭建开放的学习交流平台。社区通过理事会方式运作,由全产业链共同建设、共同运营、共同享有,推动国产AI生态繁荣发展。

更多推荐