将root用户的密码修改之后,再用Navicat连接mysql会报错,如图。


使用cmd却可以正常使用mysql,如图



解决方案:

重新修改下密码
mysql -uroot -proot
SET PASSWORD = PASSWORD('root');

或者控制台进去直接更新密码:

mysql -uroot -proot

update user set authentication_string = password('password'), password_expired = 'N', password_last_changed = now() where user = 'root';
flush privileges;

Logo

魔乐社区(Modelers.cn) 是一个中立、公益的人工智能社区,提供人工智能工具、模型、数据的托管、展示与应用协同服务,为人工智能开发及爱好者搭建开放的学习交流平台。社区通过理事会方式运作,由全产业链共同建设、共同运营、共同享有,推动国产AI生态繁荣发展。

更多推荐