mysql设置用户权限错误解决办法:ERROR 1410 (42000): You are not allowed to create a user with GRANT
·
mysql设置用户权限错误解决办法:ERROR 1410 (42000): You are not allowed to create a user with GRANT
文章目录
一、错误描述
使用mysql 8.0.34给一个已经存在的用户mall设置权限时,使用GRANT ALL PRIVILEGES ON mall_db.* TO 'mall'@'localhost' IDENTIFIED BY 'PW'时出现错误ERROR 1410 (42000): You are not allowed to create a user with GRANT
二、解决办法
经过网上查阅得知mysql 8.0.13以后的版本授权指令要分开执行,但是针对的是没有创建用户的场景下,一次性创建用户和指定权限,不过本次已经提前创建了用户,只进行权限的指派,所以不是这个问题导致的。
根本原因是创建用户时没有指定用户的host,这样系统会自动分配host为%,而不是localhost,所以需要先更改host为localhost,使用select user,host from mysql.user查看目前用户的host,然后执行以下指令将用户host进行修改:
update user set host='localhost' where user='mall';
再执行以下指令指派权限:
GRANT ALL PRIVILEGES ON mall_db.* TO 'mall'@'localhost' with grant option;
问题解决
魔乐社区(Modelers.cn) 是一个中立、公益的人工智能社区,提供人工智能工具、模型、数据的托管、展示与应用协同服务,为人工智能开发及爱好者搭建开放的学习交流平台。社区通过理事会方式运作,由全产业链共同建设、共同运营、共同享有,推动国产AI生态繁荣发展。
更多推荐


所有评论(0)